SharePoint Ajax Webpart web.config Probleme

Hallo ich verwende AJAX Extensions 1.0 in meinem Webpart. Es funktioniert großartig, wenn ich es auf SharePoint hinzufügen und alles läuft gut. Ich habe auch Links zu anderen Anwendungen, die als IFRAME auf SharePoint gestellt werden. Es tritt ein Problem mit der Anwendung auf, die von meiner SharePoint web.config erbt. Ich erhalte diesen Fehler im IFRAME:

Parser-Fehlermeldung: Der Eintrag 'ScriptModule' wurde bereits hinzugefügt.

Line 98:        <!-- ASP.NET AJAX -->
Line 99:        <httpModules>
Line 100:           <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
Line 101:       </httpModules>
Line 102:       <compilation debug="true">

Ich denke, das liegt daran, dass die SharePoint web.config auch diese Zeile enthält. Ich kann es nicht von dort entfernen, weil ich es für mein Webpart brauche. Ich dachte darüber nach, <clear/> in my IFRAME applications to get around this but I have so many applications and I am not sure if there is more than once place I will need to do this. Is there a better solution? Thanks. in meine IFRAME-Anwendungen hinzuzufügen, um dies zu umgehen, aber ich habe so viele Anwendungen und ich bin mir nicht sicher, ob es mehr als einmal einen Ort gibt, an dem ich dies tun muss. Gibt es eine bessere Lösung? Danke.

Antwort auf "SharePoint Ajax Webpart web.config Probleme " 2 von antworten

Probieren Sie diese

<httpModules> <clear />
<add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
</httpModules>